运行npm install时出现错误

时间:2018-08-24 18:46:52

标签: npm npm-install

我遇到这种错误。

C:\Users\Sulagna(mana)\Desktop\Angular Application\quickstart-master>npm install
npm WARN deprecated [email protected]: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm ERR! Unexpected end of JSON input while parsing near '...Shrinkwrap":false,"di'

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\Sulagna(mana)\AppData\Roaming\npm-cache\_logs\2018-08-24T18_43_22_701Z-debug.log

C:\Users\Sulagna(mana)\Desktop\Angular Application\quickstart-master>

有人知道如何解决吗?

2 个答案:

答案 0 :(得分:2)

  1. 删除 node_modules 文件夹
  2. npm cache clean --force
  3. npm install

答案 1 :(得分:0)

它说npm软件包[email protected]具有安全漏洞,因此要求您将其更新到版本3.0.2

您将需要更新package.json中的minimatch版本。